KB0237: Azure Information Protectionアドインとの競合:PowerPointおよびExcelでのサブクラス化エラー

  1. ホーム
  2. リソース
  3. ナレッジ ベース
  4. KB0237

問題

PowerPointまたはExcelを閉じると、次のエラーメッセージが表示されます:
CRITICALWITHMSG library\ui\win\safesubclassimpl.cpp(392): APIERR 1400 Invalid window handle.

複数のPowerPoint(またはExcel)ファイルを開いており、Microsoft Azure Information Protection(AIP)バーがリボンの下に表示されている場合、最後のPowerPoint(またはExcel)ファイルを閉じる際にこのエラーが発生することがあります。ただし、他のアドインも存在している必要があります。この問題は、たとえばCapital IQが有効な場合などに確実に再現できます。詳細な再現手順については、こちらをクリックしてください: もっと読む

thinkcell、Microsoft AIP、Capital IQでの再現:

  1. 新しい空白のPowerPoint[またはExcel]ファイルを開きます
  2. 2つ目の新しい空白のPowerPoint[またはExcel]ファイルを開きます(例:CTRL+N)
  3. Microsoft AIPバーがリボンの下に表示されていることを確認します:Home > Sensitivity> Show Barにチェックを入れる
  4. S&P Capital IQタブに移動します
  5. Charting > Charting > Launch Chart Builder
  6. 2つ目のファイルを閉じる > Don't Save
  7. 1つ目のファイルを閉じる > Don't Save
    > CRITICALWITHMSG library\ui\win\safesubclassimpl.cpp(390): APIERR 1400 Invalid window handle.

説明

thinkcellで発生するこのようなエラーは、別のアドインのプログラミングエラーが原因です。当社の開発者がこの問題を詳細に分析しました。このケースでは、Microsoft Azure Information Protection(AIP)アドインが原因です。当社の分析によると、複数のアドインが存在する場合、フック/アンフックの問題によってこの問題が発生します。 もっと読む

フックとは、関数がイベントをアプリケーションに到達する前に傍受できるようにする仕組みです。この関数はイベントに対して処理を行い、場合によってはイベントを変更または破棄できます。詳細については、KB0201 を参照してください。

このような問題を引き起こすことが知られているその他のアドインは、KB0169に記載されています。

解決策

Microsoftから、AIPクライアントはメンテナンスモードにあるとのフィードバックを受け取りました。Microsoftは、特に「アドインは他のアドインと競合し、Officeアプリのハング、クラッシュ、またはアドインの自動無効化を引き起こす可能性があるため、安定性が低い」ことから、OfficeでAIPアドインを使用することを推奨していません。代わりに、MicrosoftはOfficeアプリ向けのMicrosoft Information Protection(MIP)組み込みラベル付けの使用を推奨しています。

回避策

PowerPointおよびExcelでリボンの下にあるMicrosoft AIPバーをオフにすると、問題は解消するようです。オフにするには、Home > Sensitivity > Show barのチェックを外します。いずれの場合も、社内IT部門にご相談ください。

サポートに問い合わせる

Microsoft AIPアドインなしでも引き続き問題が発生している場合は、以下の手順に従ってください:

thinkcellログ ファイルを送ってください。これを行うには、PowerPointまたはExcelのリボンで [Insert > thinkcell > Tools Tools Menu icon > Help > Request Support] を選択します。ログ ファイルが自動的に添付された状態で、新しいメールが開きます。

[サポートをリクエスト] がPowerPointでもExcelでもうまく行かない場合は、以下の手順に従ってください。 もっと読む

  1. ファイル エクスプローラーで新しいウィンドウを開きます。

  2. アドレス フィールドに%LOCALAPPDATA%\think-cellと入力します。入力を選択します。

    または、ディレクトリを参照してthink-cellフォルダーを開くこともできます: もっと読む

    完全な規定のファイルパスはC:\Users\USERNAME\AppData\Local\think-cellです。USERNAMEをユーザー名に置き換えます。

    このフォルダーが見つからない場合は、非表示になっている可能性があります。非表示の項目を表示させるには、エクスプローラーで次のいずれかを選択します。

    • Windows 7:[整理] > [フォルダーと検索のオプション] > [表示] > [隠しファイルとフォルダーを表示する]。
    • Windows 8、Windows 8.1、および Windows 10:[表示] > [表示/非表示] > [隠しファイル]。
    • Windows 11:[表示] > [表示させる] > [隠しファイル]。
  3. think-cellフォルダ内のlogで終わるすべてのファイルを弊社サポート チームに送信します。これらのファイルには、以下のいずれかが含まれている可能性があります。

    • EXCEL_log.log
    • POWERPNT_log.log
    • ppttc_log.log
    • setup_think-cell_VERSION_log.log
    • tcasr_log.log
    • tcindex_log.log
    • tcmail_log.log
    • tcrunxl_log.log
    • tcupdate_log.log
    • また、thinkcellがアクティブである場合は、thinkcellのバージョン情報ダイアログのスクリーンショットもお送りください。thinkcellのバージョン情報ダイアログを開くには、PowerPointまたはExcelのリボンで、[挿入] > [thinkcell] > [ツール] Tools Menu icon > [ヘルプ] > [バージョン情報] を選択します。