Datenverknüpfungen verwalten

Auf dieser Seite erfahren Sie, wie Sie Datenverknüpfungen zwischen PowerPoint und externen Datenquellen verwalten (siehe Excel-Datenverknüpfungen und Tableau-Datenverknüpfungen). So können Sie die Daten in verknüpften Elementen in Ihrer Präsentation verwalten:

  • Aktualisieren Sie einzelne verknüpfte Elemente mit neuen Daten.
  • Verwalten Sie Aktualisierungen für mehrere verknüpfte Elemente in Ihrer Präsentation auf einmal.
  • Ändern Sie die Datenquellen verknüpfter Elemente.

Die folgende Tabelle definiert bestimmte Begriffe, die auf dieser Seite vorkommen.

Begriff

Definition

Alternative Datenquelle

Eine Arbeitsmappe oder ein Arbeitsblatt, die bzw. das thinkcell als Übereinstimmung für ein Element erkennt, das aktuell mit einer anderen Arbeitsmappe verknüpft ist. Beispielsweise erkennt thinkcell eine alternative Datenquelle, nachdem Sie den Namen oder Speicherort einer Arbeitsmappe geändert haben (siehe Alternative Datenquellen).

Automatische Aktualisierung

Eine Option zur Datenaktualisierung, bei der ein verknüpftes Element automatisch mit neuen Daten aktualisiert wird, sobald thinkcell Änderungen im verknüpften Excel-Bereich erkennt (siehe Verknüpfte Elemente automatisch aktualisieren)

Datenverknüpfung

Die Verbindung, mit der Sie ein thinkcell-Element in PowerPoint mit Daten aus Excel oder Tableau aktualisieren können

Datenquelle

Die Excel-Arbeitsmappe oder das Excel-Arbeitsblatt bzw. die Tableau-Ansicht, die die Daten enthält, die mit einem Element in PowerPoint verknüpft sind

Verknüpfter Excel-Bereich

Ein Zellbereich in Excel, der die Daten für ein verknüpftes Element in PowerPoint bereitstellt

Datenverknüpfungsrahmen

Der Rahmen um einen verknüpften Excel-Bereich. Die Farbe des Rahmens zeigt den Status der Datenverknüpfung an.

Zurücksetzen

Eine Option zur Datenaktualisierung, mit der Sie die letzte Datenaktualisierung eines verknüpften Elements rückgängig machen und den vorherigen Datensatz laden können (siehe Aktualisierungen verknüpfter Elemente zurücksetzen)

Informationen zur verknüpften Datenquelle anzeigen

Wenn Sie ein verknüpftes Element auf einer Folie auswählen, werden oberhalb des Elements die folgenden Informationen zur verknüpften Datenquelle angezeigt:

  • Wenn das Element mit Excel verknüpft ist, der Name und Dateipfad der Excel-Arbeitsmappe sowie der Name des Arbeitsblatts, das den verknüpften Datenbereich enthält.
  • Wenn das Element mit Tableau verknüpft ist, die URL der Tableau-Datenquelle.

In diesem Beispiel verknüpft thinkcell das Diagramm mit einem verknüpften Bereich im Arbeitsblatt Sheet1 in C:/Users/Public/Marketing Metrics January.xlsx.

Standardmäßig werden Elemente, die mit Excel verknüpft sind, manuell aktualisiert. Wenn für ein Element neue Daten in seinem verknüpften Excel-Bereich vorliegen, wird der Auswahlrahmen um das Element grün und die Schaltfläche Update wird über dem Element angezeigt.

Um das Element mit den neuen Daten zu aktualisieren, wählen Sie das Element aus und wählen Sie dann Update aus. Alternativ wählen Sie auf der Minisymbolleiste Update Once aus.

Um ein verknüpftes Element von automatischen auf manuelle Aktualisierungen umzustellen, wählen Sie das Element aus, um seine Mini-Symbolleiste zu öffnen, und wählen Sie dann Disable Automatic Updates .

Um ein mit Tableau verknüpftes Element zu aktualisieren, wählen Sie das Element aus, um die Minisymbolleiste zu öffnen, und wählen Sie dann Update Manually aus.

thinkcell kann verknüpfte Elemente automatisch aktualisieren, sobald sich ihr verknüpfter Excel-Bereich ändert. Um automatische Aktualisierungen zu aktivieren, wählen Sie das Element aus, um die Mini-Symbolleiste zu öffnen, und wählen Sie dann Update Automatically .

Solange thinkcell eine Verbindung zum verknüpften Excel-Bereich herstellen kann, werden alle Änderungen im verknüpften Excel-Bereich automatisch im verknüpften Element angezeigt (siehe Fehlerbehebung bei Datenverknüpfungen).

Um automatische Aktualisierungen für ein verknüpftes Element zu deaktivieren, wählen Sie das Element aus, um die Mini-Symbolleiste zu öffnen, und wählen Sie dann Disable Automatic Updates oder Revert .

Um die letzte Datenaktualisierung eines verknüpften Elements rückgängig zu machen, wählen Sie das Element aus, um die Mini-Symbolleiste zu öffnen, und wählen Sie dann Revert . Sie können nur Aktualisierungen zurücksetzen, die Sie seit dem Öffnen der Präsentation vorgenommen haben. Wenn Sie eine Präsentation schließen und erneut öffnen, können Sie Aktualisierungen, die vor dem Schließen erfolgt sind, nicht zurücksetzen.

Wenn Sie Aktualisierungen von Elementen rückgängig machen, wird deren Auswahlrahmen blau und die Schaltfläche Update verschwindet, bis sich der verknüpfte Excel-Bereich erneut ändert. Um eine Datenaktualisierung erneut durchzuführen, wählen Sie das Element aus, um die Mini-Symbolleiste zu öffnen, und wählen Sie dann Update Once . Auf diese Weise können Sie zwischen der neuesten Datenaktualisierung und den vorherigen Daten wechseln, auch wenn das Element eine unterbrochene Datenverknüpfung hat (siehe Unterbrochene Datenverknüpfungen verwalten ( )).

Mehrere verknüpfte Elemente über das Dialogfeld Data Links verwalten

Wenn Ihre Präsentation viele verknüpfte Elemente enthält, kann es unpraktisch sein, deren Daten einzeln zu verwalten. Das Dialogfeld Data Links bietet einen Überblick über alle Datenverknüpfungen in Ihrer Präsentation. Verwenden Sie das Dialogfeld, um die Daten für mehrere verknüpfte Elemente gleichzeitig zu verwalten.

Übersicht über das Dialogfeld „Data Links“

Um das Dialogfeld Data Links zu öffnen, führen Sie einen der folgenden Schritte aus:

  • Wechseln Sie im PowerPoint-Menüband zu Insert > thinkcell Data und wählen Sie dann Data Links .
  • Wählen Sie im PowerPoint-Menüband Insert > thinkcell > Tools Extras Menüsymbol > Data Links .
  • Wählen Sie ein verknüpftes Element aus und wählen Sie dann die Informationen zur Datenquelle darüber aus. Alternativ wählen Sie in der Mini-Symbolleiste Open Data Links Dialog .

Auf der linken Seite des Dialogfelds werden die verknüpften Elemente in der Präsentation wie folgt angezeigt:

  • Folien, die verknüpfte Elemente enthalten, werden als Folienminiaturen angezeigt.
  • In jeder Folienminiatur werden verknüpfte Elemente als graue Platzhalter angezeigt.
  • Elemente mit einer ausstehenden Aktualisierung zeigen das grüne Aktualisierungssymbol auf ihren Platzhaltern an (siehe Verknüpfte Elemente manuell aktualisieren).

Auf der rechten Seite des Dialogfelds werden die Datenquellen für verknüpfte Elemente wie folgt aufgeführt:

  • Jede Datenquelle wird neben der ersten Folie angezeigt, die ein damit verknüpftes Element enthält.
  • Excel-Datenquellen werden nach Arbeitsmappe gruppiert. Zuerst werden der Dateiname und der Pfad der Arbeitsmappe angezeigt, danach die Arbeitsblätter, die die Daten der verknüpften Elemente enthalten.
  • Tableau-Datenquellen werden als URLs angezeigt (siehe Tableau-Datenverknüpfungen).

Wenn Sie den Mauszeiger über einen Elementplatzhalter bewegen, hebt thinkcell die Datenquelle des Elements hervor. Eine QuickInfo zeigt den Namen des Arbeitsblatts, den Dateipfad der Arbeitsmappe und den aktuellen Aktualisierungsstatus des Elements an.

Aktualisierungen für mehrere verknüpfte Elemente verwalten

Im Dialogfeld Data Links können Sie mehrere Elemente auf einmal aktualisieren, Aktualisierungen zurücksetzen oder automatische Aktualisierungen aktivieren. Sie können das Dialogfeld geöffnet lassen, während Sie Ihre Folien und verknüpften Daten bearbeiten.

  1. Wählen Sie im Dialogfeld Data Links die Elemente aus, deren Aktualisierungen Sie verwalten möchten. Mehr lesen

    Um mehrere verknüpfte Elemente auszuwählen, führen Sie einen der folgenden Schritte aus:

    • Alle mit einer Datenquelle verknüpften Elemente auswählen: Wählen Sie die Datenquelle in der rechten Spalte aus.
    • Alle verknüpften Elemente auf einer Folie auswählen: Wählen Sie die Folienminiatur aus.
    • Mehrfachauswahl: Halten Sie Ctrl gedrückt und wählen Sie dann mehrere Elementplatzhalter, Folienminiaturen oder Datenquellen aus.
    • Benachbarte Auswahl: Halten Sie Shift gedrückt und wählen Sie dann einen Bereich von Elementplatzhaltern, Folienminiaturen oder Datenquellen aus.
    • Alle verknüpften Elemente in der Präsentation auswählen: Wählen Sie Ctrl+A oder wählen Sie Select All Linked Elements.
  2. Filtern Sie Ihre Auswahl bei Bedarf nach Aktualisierungsstatus oder danach, ob ein Element mit Tableau verknüpft ist. Verwenden Sie dazu die Kontrollkästchen Filter Selection: Mehr lesen
    • Updates Available : Elemente, die nicht die neuesten Excel-Daten enthalten, sowie Elemente, deren Datenquellen noch nicht geladen sind (siehe Datenquellen erneut laden ( ))
    • Updated : Elemente, für die manuelle Aktualisierungen aktiviert sind und die die neuesten Excel-Daten enthalten
    • Automatically Updating : Elemente, für die automatische Aktualisierungen aktiviert sind
    • Tableau Data Links : Elemente, die mit Tableau verknüpft sind (siehe Tableau-Datenverknüpfungen)
  3. Wählen Sie in der schwebenden Symbolleiste auf der rechten Seite des Dialogfelds die gewünschte Aktualisierungsoption aus:

Verknüpfte Elemente finden und ihre Excel-Bereiche öffnen

Im Dialogfeld Data Links können Sie verknüpfte Elemente in Ihrer Präsentation hervorheben und zu ihnen springen. Außerdem können Sie verknüpfte Excel-Bereiche direkt aus dem Dialogfeld öffnen.

  • Um alle verknüpften Elemente in Ihrer Präsentation hervorzuheben, wählen Sie Highlight Linked Elements on Slides. Alle verknüpften Elemente werden grün hervorgehoben, bis Sie die Präsentation schließen.
  • Damit ein Element hervorgehoben bleibt, nachdem Sie PowerPoint geschlossen und erneut geöffnet haben, wählen Sie den Elementplatzhalter aus und wählen Sie dann auf der unverankerten Symbolleiste Keep Highlighted on Slides.
  • Um zu einem verknüpften Element in Ihrer Präsentation zu springen, wählen Sie den Elementplatzhalter aus. Auf der Folie wählt thinkcell das Element aus. Im Dialogfeld Data Links hebt thinkcell die Datenquelle hervor.
  • Um den verknüpften Bereich eines Elements in Excel zu öffnen, doppelklicken Sie auf den Elementplatzhalter.

Alternative Datenquellen

Wenn Sie Elemente mit Zellen in einer Excel-Arbeitsmappe verknüpfen, weist thinkcell dem verknüpften Excel-Bereich eine Datenverknüpfungs-ID zu. thinkcell verwendet diese ID, um Daten aus dem verknüpften Bereich in das zugehörige Element zu laden.

Wenn Sie die verknüpfte Excel-Arbeitsmappe umbenennen, verschieben, duplizieren oder freigeben, ändert sich der Dateipfad der Arbeitsmappe, ihre Datenverknüpfungs-IDs bleiben jedoch gleich. Wenn Sie die Arbeitsmappe mit dem neuen Pfad und die Präsentation gleichzeitig öffnen, erkennt thinkcell eine weitere Arbeitsmappe mit derselben Datenverknüpfungs-ID. Daher bietet thinkcell diese Arbeitsmappe als alternative Datenquelle für die Elemente an, die mit der ursprünglichen Arbeitsmappe verknüpft sind. Ebenso erkennt thinkcell ein Arbeitsblatt als alternative Datenquelle, wenn Sie ein Arbeitsblatt duplizieren oder umbenennen, das einen verknüpften Bereich enthält.

Eine alternative Datenquelle ersetzt die ursprüngliche Datenquelle nicht automatisch, auch wenn die ursprüngliche Quelle nicht mehr verfügbar ist. Elemente bleiben mit ihrer ursprünglichen Quelle verknüpft, bis Sie sie mit einer anderen Datenquelle verknüpfen.

Wenn Sie Ihre Office-Sitzung beenden, löscht thinkcell die Liste der alternativen Datenquellen. Um diese Quellen in einer neuen PowerPoint-Sitzung wieder verfügbar zu machen, öffnen Sie die entsprechenden Excel-Arbeitsmappen erneut.

In PowerPoint weist Folgendes darauf hin, dass thinkcell eine oder mehrere alternative Datenquellen erkannt hat:

  • Auf den Data Links -Menübandbefehlen wird ein orangefarbener Punkt angezeigt.
  • An den folgenden Stellen wird ein grünes Symbol für alternative Datenquellen ( ) angezeigt: Mehr lesen

    • Wenn Sie ein Element auswählen, das eine alternative Quelle hat, oberhalb des Elements
    • Im Dialogfeld Data Links, neben Datenquellen, die alternative Quellen haben
  • Die Schaltfläche Manage Data Sources wird an den folgenden Stellen angezeigt: Mehr lesen
    • In der Mini-Symbolleiste von Elementen, die alternative Quellen haben
    • Im Dialogfeld Data Links, in der schwebenden Symbolleiste von Elementen, die alternative Quellen haben

In Excel werden sowohl in der ursprünglichen als auch in den alternativen Datenquellen farbcodierte Registerkarten unter jedem der übereinstimmenden Datenverknüpfungsrahmen angezeigt (siehe Doppelte verknüpfte Bereiche anzeigen).

Elemente mit alternativen Datenquellen verknüpfen

Wenn thinkcell alternative Datenquellen erkennt, können Sie Elemente im Dialogfeld Manage Data Sources mit den alternativen Quellen verknüpfen. Damit thinkcell eine alternative Datenquelle erkennt, öffnen Sie die Arbeitsmappe, während die Präsentation geöffnet ist.

Um Elemente in Ihrer Präsentation mit alternativen Datenquellen zu verknüpfen, gehen Sie wie folgt vor:

  1. Wählen Sie auf Ihrer Folie oder im Dialogfeld Data Links ein oder mehrere Elemente mit alternativen Datenquellen aus (siehe Aktualisierungen für mehrere verknüpfte Elemente verwalten):
    • Um alle Verknüpfungen zu einer aktiven Arbeitsmappe durch Verknüpfungen zu einer alternativen Arbeitsmappe zu ersetzen, wählen Sie mindestens ein Element aus, das mit der aktiven Arbeitsmappe verknüpft ist. Fügen Sie Ihrer Auswahl keine Elemente hinzu, die mit einer anderen Arbeitsmappe verknüpft sind.
    • Um alle Verknüpfungen zu einem aktiven Arbeitsblatt durch Verknüpfungen zu einem alternativen Arbeitsblatt zu ersetzen, wählen Sie mindestens ein Element aus, das mit dem aktiven Arbeitsblatt verknüpft ist. Fügen Sie Ihrer Auswahl keine Elemente hinzu, die mit einem anderen Arbeitsblatt verknüpft sind.
    • Wenn Sie nur einige Verknüpfungen zu einer Arbeitsmappe oder einem Arbeitsblatt ersetzen möchten, wählen Sie die Elemente aus, die Sie mit der alternativen Quelle verknüpfen möchten.
  1. Öffnen Sie bei ausgewählten Elementen das Dialogfeld Manage Data Sources. Mehr lesen
    • Um Manage Data Sources von Ihrer Folie aus zu öffnen, führen Sie einen der folgenden Schritte aus:
      • Wählen Sie oberhalb eines ausgewählten Elements das grüne Symbol für alternative Quellen ( ) aus.
      • Wählen Sie in der Mini-Symbolleiste Manage Data Sources.
    • Um Manage Data Sources aus dem Dialogfeld Data Links zu öffnen, wählen Sie in der schwebenden Symbolleiste Manage Data Sources.
  2. Wählen Sie unter Manage Data Sources die gewünschte alternative Datenquelle aus. Mehr lesen

    Das Dialogfeld Manage Data Sources listet alle verfügbaren Datenquellen für die von Ihnen ausgewählten Elemente auf. Datenquellen werden nach Arbeitsmappe gruppiert:

    • Zuerst werden Dateiname und Pfad der Arbeitsmappe angezeigt.
    • Unter jeder Arbeitsmappe befindet sich eine Liste der Arbeitsblätter, die die Daten der ausgewählten Elemente enthalten.
      • Arbeitsblätter, die mit den ausgewählten Elementen verknüpft sind, haben das Symbol Active neben sich.
      • Arbeitsblätter, die neue alternative Datenquellen sind, haben das Symbol New neben sich.

    Um Verknüpfungen zu einer aktiven Arbeitsmappe durch Verknüpfungen zu einer alternativen Arbeitsmappe zu ersetzen, wählen Sie die gewünschte alternative Arbeitsmappe aus.

    Um Verknüpfungen zu einem aktiven Arbeitsblatt durch Verknüpfungen zu einem alternativen Arbeitsblatt zu ersetzen, wählen Sie das gewünschte alternative Arbeitsblatt aus.

  3. Wählen Sie aus, welche Elemente Sie mit der alternativen Datenquelle verknüpfen möchten.
    • Selected Elements: Verknüpft nur die ausgewählten Elemente mit der alternativen Quelle.
    • Elements Linked to the Same Worksheet: Ersetzt alle Verknüpfungen zum aktiven Arbeitsblatt durch Verknüpfungen zum alternativen Arbeitsblatt.
    • Elements Linked to the Same Workbook: Ersetzt alle Verknüpfungen zur aktiven Arbeitsmappe durch Verknüpfungen zur alternativen Arbeitsmappe.
  1. Standardmäßig trennt thinkcell die Datenverknüpfung, wenn die alternative Datenquelle keinen passenden Datenbereich für ein Element enthält. Wenn Sie stattdessen möchten, dass ein Element in diesem Fall mit der vorherigen Datenquelle verknüpft bleibt, wählen Sie Skip elements that don't have matching data ranges in the new source.
  2. Wählen Sie OK.

Um die Änderungen rückgängig zu machen, die Sie an Datenquellen vorgenommen haben, wählen Sie Ctrl+Z. Alternativ wählen Sie in der Symbolleiste für den Schnellzugriff von PowerPoint Undo Last (siehe Microsoft-Support).

Wenn Ihre Präsentation verknüpfte Elemente enthält, muss thinkcell die verknüpften Datenquellen laden, sobald Sie eine neue Office-Sitzung starten. Wenn thinkcell die Datenquelle in der aktuellen Office-Sitzung noch nicht geladen hat, laden Sie die Datenquelle erneut, um die Datenverknüpfung wiederherzustellen. Wenn thinkcell die Datenquelle nicht öffnen kann, ist die Datenverknüpfung unterbrochen. In den folgenden Abschnitten erfahren Sie, wie Sie Datenquellen erneut laden und unterbrochene Datenverknüpfungen verwalten.

Datenquellen erneut laden ( )

Wenn die Datenquelle eines verknüpften Elements in der aktuellen Office-Sitzung noch nicht geladen ist, wird an den folgenden Stellen ein orangefarbenes Fragezeichen ( ) angezeigt:

  • Oberhalb des Elements, wenn Sie es auswählen. Die QuickInfo enthält die Meldung "Not yet loaded."
  • Auf der Schaltfläche Update Available oder Automatic Updates Enabled
  • Im Dialogfeld Data Links, neben der Datenquelle des verknüpften Elements (siehe Mehrere verknüpfte Elemente über das Dialogfeld Data Links verwalten). Die QuickInfo enthält die Meldung "Not yet loaded."

Um die Datenquelle zu laden und die Datenverknüpfung wiederherzustellen, gehen Sie wie folgt vor:

  1. Wählen Sie das Element aus.
  2. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie die Datenquelle aus, die oberhalb des Elements angezeigt wird.
    • Wählen Sie in der Minisymbolleiste Update Once oder Update Automatically .
    • Öffnen Sie die Excel-Arbeitsmappe, die die verknüpften Daten enthält. Doppelklicken Sie beispielsweise auf das Element oder öffnen Sie die Arbeitsmappe über den Datei-Explorer.

Wenn thinkcell den verknüpften Excel-Bereich finden kann, wird die Datenverknüpfung wiederhergestellt und die orangefarbenen Fragezeichen verschwinden.

Unterbrochene Datenverknüpfungen verwalten ( )

Wenn thinkcell die Datenquelle eines verknüpften Elements nicht öffnen kann, wird an den folgenden Stellen ein rotes Ausrufezeichen ( ) angezeigt:

  • Oberhalb des Elements, wenn Sie es auswählen. Die QuickInfo enthält die Meldung "File cannot be opened."
  • Auf der Schaltfläche Update Available , Update Once oder Automatic Updates Enabled
  • Im Dialogfeld Data Links, neben der Datenquelle des Elements (siehe Mehrere verknüpfte Elemente über das Dialogfeld Data Links verwalten). Die QuickInfo enthält die Meldung "File cannot be opened."

Häufige Ursachen für unterbrochene Datenverknüpfungen sind das Verschieben oder Umbenennen der Datenquelle.

Um unterbrochene Datenverknüpfungen wiederherzustellen, ändern Sie die Datenquellen der verknüpften Elemente (siehe Elemente mit alternativen Datenquellen verknüpfen).

Datenblatt von Elementen mit unterbrochenen Datenverknüpfungen bearbeiten

Wenn eine Datenverknüpfung nicht wiederhergestellt werden kann, speichert thinkcell eine Kopie der zuletzt verwendeten Daten aus der verknüpften Datenquelle im Datenblatt des Elements (siehe Elementdatenblätter).

Wenn Sie das Datenblatt öffnen und bearbeiten und das Element später mit einem Excel-Bereich verknüpfen, aktualisiert thinkcell das Element nicht sofort. So wird verhindert, dass Sie die Daten im Datenblatt des Elements versehentlich überschreiben. Nachdem Sie das Element mit dem neuen Excel-Bereich verknüpft haben, können Sie das Element manuell mit den neuen Daten aktualisieren oder automatische Aktualisierungen aktivieren.

Wenn Sie eine Datenverknüpfung entfernen, wird ein bestimmtes Element in PowerPoint von seinem verknüpften Zellbereich in Excel getrennt. Wenn Sie eine Datenverknüpfung entfernen, ändern sich die Excel-Daten nicht. In PowerPoint bleibt das Element in der Präsentation, und sein aktuellster Datensatz wird im Datenblatt des Elements gespeichert (siehe Elementdatenblätter).

Wenn Sie eine Datenverknüpfung in PowerPoint entfernen, behält der verknüpfte Excel-Bereich alle anderen Datenverknüpfungen zu anderen Elementen. Wenn Sie eine Datenverknüpfung in Excel entfernen, unterbrechen Sie alle Datenverknüpfungen, die den verknüpften Bereich in PowerPoint verwenden (siehe Unterbrochene Datenverknüpfungen verwalten ( )).

Datenverknüpfungen in PowerPoint entfernen

Um Datenverknüpfungen von Elementen in PowerPoint zu entfernen, führen Sie einen der folgenden Schritte aus:

  • Wählen Sie ein oder mehrere Elemente aus, deren Datenverknüpfungen Sie entfernen möchten (siehe Objekte auswählen). Klicken Sie mit der rechten Maustaste auf die Auswahl, um das Kontextmenü zu öffnen, und wählen Sie dann Break Excel Link oder Break Tableau Link .
  • Wählen Sie im Dialogfeld Data Links die Platzhalter der Elemente aus, deren Verknüpfungen Sie entfernen möchten (siehe Aktualisierungen für mehrere verknüpfte Elemente verwalten). Drücken Sie dann Delete, oder wählen Sie in der unverankerten Symbolleiste Break Excel Link oder Break Tableau Link .
  • Um alle Datenverknüpfungen zu einer bestimmten Excel-Quelle zu entfernen, wählen Sie im Dialogfeld Data Links die Arbeitsmappen oder Arbeitsblätter aus, die Sie entfernen möchten. Drücken Sie dann Delete.
Datenverknüpfungen in Excel entfernen

Um eine Datenverknüpfung aus einem Excel-Bereich zu entfernen, führen Sie einen der folgenden Schritte aus:

  • Wählen Sie den Datenverknüpfungsrahmen um den Bereich aus und drücken Sie dann Delete.
  • Klicken Sie mit der rechten Maustaste auf den Datenverknüpfungsrahmen um den Bereich. Wählen Sie im Kontextmenü Delete Symbol Löschen .

Um unterbrochene Datenverknüpfungen zu identifizieren, öffnen Sie sowohl die Excel-Arbeitsmappe als auch alle PowerPoint-Dateien, mit denen die Arbeitsmappe verknüpft ist. Alle verknüpften Excel-Bereiche haben einen roten Rahmen, wenn die verknüpften PowerPoint-Dateien geschlossen sind. Wenn ein Datenverknüpfungsrahmen auch nach dem Öffnen der PowerPoint-Datei rot ist, ist die Verknüpfung unterbrochen.

Um alle unterbrochenen Datenverknüpfungen in der Arbeitsmappe zu entfernen, führen Sie einen der folgenden Schritte aus:

  • Klicken Sie mit der rechten Maustaste auf den roten Rahmen einer unterbrochenen Datenverknüpfung. Wählen Sie im Kontextmenü Delete Disconnected Links .
  • Wählen Sie im Excel-Menüband Insert > thinkcell > Tools Extras Menüsymbol > Delete Disconnected Links .

Wenn Sie thinkcell Essentials haben, können Sie keine thinkcell-Diagramme oder anderen Elemente, die mit Datenbereichen verknüpft sind, in Ihre Präsentation einfügen. Wenn Ihre Präsentation jedoch bereits verknüpfte Elemente enthält, können Sie Folgendes tun:

FAQ zu Excel-Datenverknüpfungen

Was passiert, wenn ich verknüpfte Elemente kopiere?

Wenn Sie ein verknüpftes Element kopieren, sind sowohl das Original als auch die Kopie mit demselben Excel-Bereich verknüpft (siehe Verknüpfte Elemente manuell aktualisieren).

Was passiert, wenn ich verknüpfte Elemente lösche?

Wenn Sie ein verknüpftes Element löschen, entfernen Sie auch seine Datenverknüpfung zu Excel. Wenn keine anderen Elemente in einer geöffneten Präsentation mit demselben Excel-Bereich verknüpft sind, wird der Rahmen um den Bereich rot. Der verknüpfte Bereich wird ansonsten nicht beeinträchtigt. Weitere Informationen finden Sie unter Datenverknüpfungen entfernen.

Wie werde ich die roten Rahmen in meinen Excel-Arbeitsblättern los?

Ein roter Rahmen um einen verknüpften Bereich zeigt an, dass keine geöffneten Präsentationen Datenverknüpfungen zu diesem verknüpften Bereich enthalten. Mögliche Gründe für einen roten Datenverknüpfungsrahmen sind:

  • Die verknüpften Elemente befinden sich in einer Präsentation, die nicht geöffnet ist.
  • Die verknüpften Elemente oder die Präsentationen, in denen sie enthalten waren, wurden gelöscht.
  • Die verknüpften Elemente verwenden jetzt einen anderen verknüpften Excel-Bereich als Datenquelle.

Weitere Informationen dazu, wie Datenverknüpfungsrahmen farblich codiert sind, finden Sie unter Verknüpfte Bereiche in Excel verwalten. Informationen zum Entfernen von Datenverknüpfungen in Excel finden Sie unter Datenverknüpfungen in Excel entfernen.

Warum zeigen meine verknüpften Elemente eine ausstehende Aktualisierung an, obwohl sich die Excel-Daten nicht geändert haben?

Selbst kleine Änderungen in Excel-Daten, etwa Änderungen an Dezimaltrennzeichen oder Währungssymbolen, werden für ein verknüpftes Element als neue Daten erfasst.

Wenn Ihnen ausstehende Aktualisierungen für ein verknüpftes Element angezeigt werden, obwohl Sie sicher sind, dass im verknüpften Excel-Bereich keine neuen Daten vorhanden sind, überprüfen Sie das Datenblatt des Elements. Ausstehende Aktualisierungen können darauf hinweisen, dass das Element eine unterbrochene Verknüpfung hatte und Sie seine Daten im Elementdatenblatt bearbeitet haben, bevor Sie die Datenverknüpfung mit Excel wiederhergestellt haben (siehe Unterbrochene Datenverknüpfungen verwalten ( )).

Warum ist Excel langsam, wenn ich viele verknüpfte Bereiche habe?

Die automatische Fehlerüberprüfung von Excel beeinträchtigt die Leistung. Sie können die Leistung von Excel verbessern, indem Sie die automatische Fehlerüberprüfung deaktivieren.

  1. Wechseln Sie im Excel-Menüband zu File > Excel Options.
  2. Wählen Sie im Dialogfeld Excel Options die Registerkarte Formulas aus.
  3. Deaktivieren Sie im Abschnitt Error Checking die Option Enable background error checking.

Ich habe viele Excel-Dateien, die ich mit thinkcell visualisieren möchte. Kann ich thinkcell im Batchmodus ausführen?

Ja, thinkcell bietet Funktionen, um Diagramme programmgesteuert mit Daten aus Excel-Bereichen zu aktualisieren und vollständige Präsentationen aus Vorlagen zu erstellen. Weitere Informationen finden Sie unter Automatisierung mit Excel-Daten.

Welche Vorteile bieten Excel-Datenverknüpfungen gegenüber Microsoft OLE?

Microsoft Office unterstützt Object Linking and Embedding (OLE), womit Excel-Tabellen und -Diagramme in PowerPoint verknüpft oder eingebettet werden können. Wie die Datenverknüpfungen von thinkcell können Sie verknüpfte OLE-Objekte aktualisieren, wenn sich ihre Quelldaten ändern.

Die Datenverknüpfungen von thinkcell wurden speziell für datengestützte Präsentationselemente entwickelt und bieten gegenüber Microsoft OLE die folgenden Vorteile:

  • Das Element bleibt ein thinkcell-Element. Durch die Verknüpfung mit Excel wird es nicht durch ein Excel-Objekt ersetzt. Sie können ein verknüpftes thinkcell-Element in PowerPoint wie jedes andere thinkcell-Element formatieren und bearbeiten.
  • Das Element bleibt auch ohne seine Excel-Datenquelle bearbeitbar. thinkcell speichert die neuesten Daten des Elements im Datenblatt des Elements, sodass Sie die Daten weiterhin anzeigen und bearbeiten können, wenn die Arbeitsmappe nicht verfügbar ist.
  • Sie können ein vorhandenes thinkcell-Element mit Excel verknüpfen, ohne es aus Excel-Inhalten neu zu erstellen.
  • Sie haben mehr Kontrolle über Aktualisierungen. Sie können Elemente manuell aktualisieren, sie automatisch aktualisieren, wenn sich Excel-Daten ändern, oder die letzte Aktualisierung rückgängig machen, die Sie innerhalb der aktuellen PowerPoint-Sitzung vorgenommen haben.
  • Sie können alle Verknüpfungen in der Präsentation an einer zentralen Stelle verwalten. Im Dialogfeld Data Links können Sie alle verknüpften Elemente anzeigen, Verknüpfungen nach Aktualisierungsstatus filtern und mehrere Elemente nach Folie, Arbeitsmappe oder Arbeitsblatt auswählen oder aktualisieren.
  • Sie können mehrere Elemente auf eine andere Quelle umstellen. Wenn eine verknüpfte Arbeitsmappe oder ein verknüpftes Arbeitsblatt verschoben, umbenannt oder kopiert wird, kann thinkcell dies als alternative Quelle erkennen. Sie können mehrere Elemente gleichzeitig auf die aktualisierte alternative Quelle umstellen.

Im Vergleich dazu bleibt ein verknüpftes OLE-Objekt an seine Quellanwendung und externe Datei gebunden. PowerPoint kann das OLE-Objekt aktualisieren, seine Quelle ändern oder die Verknüpfung trennen, OLE-Objekte bieten jedoch nicht die präsentationsweite Verknüpfungsverwaltung, das Rückgängigmachen von Aktualisierungen, die Datenzuordnung oder Workflows für alternative Quellen von thinkcell.

Brauchen Sie Hilfe bei der Fehlerbehebung?

Besuchen Sie unsere Knowledge Base